mne-bids-pipeline: Critical Error digitisation points

Hello again,

The mne-bids-pipeline is great :slight_smile: but due to my lack of experience I keep running into problems (I am using Python 3.9 and mne 1.1dev0).

I used a 10-10 easy cap system with 64 electrodes, therefore I chose the
eeg_template_montage = ‘easycap-M10’

Using this, I got the following error:

I also tried the standard_1005, which worked but the single electrode traces were generated in black, which I did manage to change:

Using no specification eeg_template_montage = None worked well.

Would you be able to provide some advice which eeg_template_montage specification would be the best for a 10-10 easy cap system with 64 electrodes, and what went wrong with the other setups?

Thanks, any help is much appreciated!

this is likely a bug in the pipeline.

do you have a dataset (one subject is enough) you can share so we can investigate?


I already have some sample data from @fraenni and can try to take a look (or share with you) :slight_smile:

OK I’ll let you have a look

This is actually something I’d consider a bug in MNE-BIDS, but needs to be discussed with the other developers. I’m tracking this here:

1 Like

In a quick test where I directly loaded your data with MNE-BIDS (i.e., outside of the pipeline), I used easycap-M1 and it seems to be working fine:

# %%
from pathlib import Path
import mne_bids

bids_root = Path('~/Development/Support/mne-python/Franziska Knolle/input')
bp = mne_bids.BIDSPath(
raw = mne_bids.read_raw_bids(bp)
    sphere='eeglab'  # new in MNE 1.1


Please note that this idealized montage is not recommended for source estimation.

I cannot reproduce this locally, and honestly it looks like a bug in MNE or something – not only are all traces black, but also the electrodes shown on the head circle (top left of the traces subplot).

Do you see this issue for the evoked contrasts only? Or also for the “normal” evoked plots?

Could you try updating MNE-Python to version 1.1 and see if the problem persists?


Hi Richard,
thanks for your help!

RE easycap-M10: Okay - weird - I will try it again then. thanks for checking!!

RE standard_1005. Yes I do get that also for normal evoked plots.

I am using mne 1.1dev0 - is that what you mean or is there a newer version?


Thank you! We released MNE-Python 1.1 a few days ago. It’s worth installing to try and see if it fixes your issue. There is an incompatibility with autoreject, but I don’t think you’re currently using autoreject anyway.

Best wishes,