'MNEQtBrowser' error


I am new to mne.
I tried to install mne with its gui function meggie.
After trying to do the most basic operation, i.e., load a file and draw data, I get the error:

AttributeError: ‘MNEQtBrowser’ object has no attribute ‘canvas’

I know that meggie is separated from mne, but maybe someone can help understand what is the source of the problem.

I am working with linux Ubuntu 20.04.5 LTS
mne version is 1.2.2

Instalation was carried with conda under --channel=conda-forge with python 3.9.15 (though the same error appears also when using python 3.10.6).

Will be thankful for any help.

how did you install mne?


Thanks for the reply.

In a virtual environment created especially for mne:

conda install python=3.10
conda install -c conda-forge meggie

Alternatively (producing the same error):

conda install python=3.10
conda install -c conda-forge mne
conda install -c conda-forge meggie

is it possible that meggie makes you use a different of QT?

can you try without install meggie?


I do not know. Maybe meggie uses different QT (or maybe it just not updated) Is there any other GUI interface for mne?

I will have to learn how to use the non-gui interface. It will take me some time. Thanks for the advice.

can you ask the author of meggie?


ping @Teekuningas, question about meggie here. :point_up:

1 Like

…meanwhile, one option would be to use the matplotlib backend instead of the QtGraph backend. It might work (matplotlib sometimes also uses Qt for its windows, but you can set it to use something else). See mne.viz.set_browser_backend — MNE 1.2.2 documentation and Backends — Matplotlib 3.6.2 documentation.

Dear Dan,

Thanks for the reply.

I have contacted Erkka Heinilä, one of the authors of Meggie. She also said that the error occurs since the new plot browser of mne-python was only recently introduced. They (Meggie people) will fix the bug shortly.

In the meanwhile, she also suggested using the MNE_BROWSER_BACKEND set matplotlib using the command:

MNE_BROWSER_BACKEND=matplotlib meggie

That worked nicely.

Thanks for the help.


1 Like