Problem with read_raw_fif - numpy.dtype[float64]

  • MNE-Python version: 0.23.0
  • operating system: window 7

I downloaded sample MEG data from MNE website. I tried to load raw fif file. But, it showed error message as below:

I also tried with MNE-Python version: 0.22.1. There was no problem at all.

How can I fix it under v0.23? Any help would be greatly appreciated.


Hello, sorry to hear you’re having problems. I assume there is some incompatibility with / between some of the numeric and scientific Python packages you have installed.

Please follow the official installation instructions to create a fresh, clean conda environment to run MNE from.

I have to add that I’m not sure that we even still support Windows 7 … it’s ancient and officially has reached its end-of-life.

Thanks Richard for speedy reply. I tried what you said. It appears it’s time to switch to Linux. I will keep trying and providing feedback. Great thanks.

Hi Richard,

A quick feedback. On the window computer, I followed the official installation instructions and created mne environment. It still works on the ancient os!!! But, I still switch to Linux for good. Thanks for your help.

1 Like