Error using MNE for fNIRS BOXY data

Hello All,
I’m new to MNE, I am trying to use MNE to read BOXY data and received an error saying “MNE has not been tested with BOXY version(0.82)”. I’m not sure how to go ahead from there, has anyone else faced the same error? any suggestions on how to solve this is appreciated
Thank you.

tagging @rob-luke who may be able to answer this one.

I took a look at the code and it is as you describe. It throws an error if it’s a file version we haven’t tested against.

I have raised a GitHub issue to see if we should change it to an warning instead. See How to handle untested file versions with read raw body? · Issue #9475 · mne-tools/mne-python · GitHub

How proficient are you with coding? Could you comment out the warning and test the function with your data to verify it works? Do you have access to a measurement device and could you provide test data?

I’ve worked in matlab before but am new to python environment. I commented the warning and received " IndentationError: expected an indented block". So, I commented the entire ‘# Check that the BOXY version is supported’ part and got “ValueError: could not convert string to float: ‘BOXY.EXE:’”
I do not know how to correct from there.
Here is a link to the sample test phantom data.