raw.plot() causes segmentation fault

  • MNE version: 1.8.0
  • operating system: Sonoma 14.5 (Apple M1)

I’m trying to do the MNE tutorial with Jupyterlab, but every time I ran ‘raw.plot()’, it terminates the mne kernel.

I would really like to use the MNE package for my research, so it would be very helpful if anyone could solve this issue.

Best regards,

The following is the system information.

Platform macOS-14.5-arm64-arm-64bit
Python 3.9.1 (default, Aug 31 2023, 18:13:59) [Clang 14.0.3 (clang-1403.]
Executable /Users/yamadashoto/.pyenv/versions/3.9.1/bin/python
CPU arm (8 cores)
Memory 16.0 GB

├☑ mne 1.8.0.dev60+ga307bbd5ea9 (devel, latest release is 1.7.0)
├☑ numpy 1.22.4 (unknown linalg bindings (threadpoolctl module not found: No module named ‘threadpoolctl’))
├☑ scipy 1.7.3
└☑ matplotlib 3.8.2 (backend=module://matplotlib_inline.backend_inline)

Numerical (optional)
├☑ nibabel 5.2.1
├☑ pandas 2.0.3
├☑ h5io 0.2.3
├☑ h5py 3.10.0
└☐ unavailable sklearn, numba, nilearn, dipy, openmeeg, cupy

Visualization (optional)
├☑ pyvista 0.43.9 (OpenGL 4.1 Metal - 88.1 via Apple M1)
├☑ pyvistaqt 0.11.0
├☑ vtk 9.3.0
├☑ qtpy 2.4.1 (PyQt5=5.15.11)
├☑ ipywidgets 8.1.3
└☐ unavailable ipympl, pyqtgraph, mne-qt-browser, trame_client, trame_server, trame_vtk, trame_vuetify

Ecosystem (optional)
└☐ unavailable mne-bids, mne-nirs, mne-features, mne-connectivity, mne-icalabel, mne-bids-pipeline, neo, eeglabio, edfio, mffpy, pybv

Hello and welcome to the forum! This is likely due to an incompatibility between your Python binary and Qt. Please follow the installation instructions on our website, or use the stand-alone installer.

Best wishes,

Hello Richard!
Thank you very much for your reply!

I actually tried the installer first, which terminated the kernel. I then created another kernel with the ‘pip’ method, which again terminated the new kernel in the same fashion…

Best wishes,

Hello, can you try installing via the conda method please? That should work in any case…


I tried the conda method, but the same problem continues…

$ conda create --channel=conda-forge --strict-channel-priority --name=mne mne

$ conda install --name=base nb_conda_kernels

I first tried these, but the kernel for the new mne environment did not show up in jupyter notebook & jupyter lab.
So I additionally ran the following code

python -m ipykernel install --user --name mne_env

I’ve done things wrongly maybe…
If you could spot it, it would be really helpful…

Thank you for your help.

Best wishes,

I think you need to install this into the mne environment, not into base

Or maybe you need ipykernel in mne? I’m not sure
Why don’t you just install Jupyter Lab into the mne environment and start it from there?

That was the cause of the crush apparently.

Once I adjusted the name accordingly like the following,
everything worked out!

$ conda install --name=mne nb_conda_kernels

python -m ipykernel install --user --name mne

Thank you very much for your help!

Best wishes,

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.