Problem with BIDS emptyroom

  • MNE-Python version: 0.23.0
  • operating system: ubuntu

I have an error message from creating MNE-BIDS for empty room as below. When I ran ‘write_raw_bids’ for empty room data, it showed this error message.

I also attached my script below.

I run the similar script for raw data. It was totally fine. Is there any suggestions? Many thanks.

Hello @TYH, which version of MNE-BIDS is this? We recently released 0.8, can you please try with this version?

Hi @richard, I use 0.8 version though. Is there any other connected package version which I should pay attention?

This is actually supposed to work :thinking: Could you share a minimal working example so I can try to reproduce this?

No problem. How to share with you? through email?or?

Email is fine as long as the file is small enough. Otherwise, Google Drive or Dropbox or similar will do, or

I just shared you one example data set and script. Thank you ~~ :blush:

1 Like

Thank you, I have received the data and will take a look.

Hello @TYH,

it appears you’ve actually caught a bug in MNE-BIDS there!

I made a fix: WIP: copyfile_kit() didn't handle acq, mrk is None by hoechenberger · Pull Request #850 · mne-tools/mne-bids · GitHub

It’s not yet been merged into our official development branch, but if you want to try it out already, you may install it via

pip install -U

I will let you know when we’ve finally merged it. Shouldn’t take more than 1 to 3 days max.

Thanks for reporting!

Best wishes,


1 Like

Hi @richard ,

Thank you very much for speedy reply, amazing!!! :star_struck: I will try it out and let you know.

Best regards,


The bug fix has been merged into the main development branch of MNE-BIDS. You can install it via

pip install -U

The fix will be included in the next official release, too.


Hi @richard,

A quick feedback. It works perfect with my data. Thank you~~

1 Like