Epochs rejection

I can’t reject epochs based on peak-to-peak amplitude by using function mne.Epochs because I’m using mne.make_fixed_length_epochs function. In this function, it doesn’t have rejection by parameters.

The reason why we use mne.make_fixed_length_epochs is in our dataset don’t have ‘events’.
So, how I can solve this problem?

Thank you :smile:

Hello, you can use epochs.drop_bad().

Best wishes,

Can this function operate in real-time signal processing?

Thank you

I don’t understand that question … For real-time processing, you should use MNE-Realtime, whose RtEpochs readily support a reject parameter.